Summary

Information relating to implementing 1E Catalog in your organization.
On this page:

Supported Platforms

This table lists all the platforms supported by 1E Catalog, and the software required to allow 1E Catalog to be installed or to work.

CategoryProductNotes

OS

  • Windows Server 2019
  • Windows Server 2016

1E Catalog will only install on computers running one of these server OS.

This list is automatically updated to show only those OS versions in mainstream support by Microsoft, and therefore supported by 1E. However, the following OS continue to be supported as exceptions to help customers with their migration to the latest OS:

  • Windows Server 2012 R2.

Please refer to Constraints of Legacy OS regarding end of mainstream support.

For Microsoft product lifecycle details, please refer to https://support.microsoft.com/en-us/lifecycle/search.

Please refer to https://1eportal.force.com/s/support-for-msft-rapid-release-cycle for details of which Current Branch versions are supported by 1E products, and known issues regarding specific versions.

Database servers

  • SQL Server 2017
  • SQL Server 2016 SP2
  • SQL Server 2016 SP1
  • SQL Server 2014 SP2

You must have one of these SQL Server versions installed, either local or remote. SQL Server Standard or Enterprise edition is recommended.

The SQL Server database instance must be configured to use a case-insensitive, accent-sensitive collation as the server default (the preferred collation is SQL_Latin1_General_CP1_CI_AS.

If installing SQL Server locally, note:

    • SQL Server 2014 requires .NET 3.5 SP1 and .NET 4.x - supported Server OS include both which will need to be enabled in Server Manager roles and features
    • SQL Server 2016 and 2017 require .NET 4.6 which requires KB2919355 on Windows Server 2012 R2
    • SQL Server setup requires PowerShell 2.0.

SQL Server Browser service is required only if you wish to browse for available SQL Server instances during installation instead of typing the instance name.

For more information about SQL Server requirements, refer to MSDN: Hardware and Software Requirements for Installing SQL Server.

Web servers

  • IIS 10
  • IIS 8.5

The server hosting 1E Catalog must have one of these Web server versions installed.

See Requirements - Server Roles and Features for details of required IIS features.

Runtime libraries

  • .NET Framework 4.8
  • .NET Framework 4.7
  • .NET Framework 4.6.2
  • .NET Framework 4.5.2

You must have one of these .NET Framework versions installed. See Requirements - Server Roles and Features for details of required .NET Framework features.

To know supported combinations of OS and .NET Framework, please refer to: https://docs.microsoft.com/en-us/dotnet/framework/migration-guide/versions-and-dependencies .

    • Windows Server 2019 has .NET Framework 4.7.2 installed by default
    • Windows Server 2016 has .NET Framework 4.6.2 installed by default
    • Windows Server 2012 R2 has .NET Framework 4.5.1 installed by default, therefore you must upgrade to one of the supported versions of .NET Framework.

See Database servers above for notes on .NET Framework and SQL Server.

Browsers

  • Google Chrome
  • Internet Explorer 11
  • Microsoft Edge
  • Mozilla Firefox

Web-based administration for the Catalog using the CatalogWeb UI is supported on the latest versions of these browsers.

Others

  • AD security group

Although not required for installation, an AD security group is required to control access for users permitted to rebuild your Catalog data, as described in Rebuilding the 1E Catalog - How to reconfigure the website to grant admin access. Members of this group will also have access to the Admin menu item in the Catalog UI.

Windows Server roles and features

Items in bold are included in the PowerShell script available for download from Preparation: Windows Server roles and features.

The following roles, role services and features must be installed/enabled as a minimum. The Name column is the reference used in PowerShell commands.

In the case of .NET Framework features we refer to 4.X in the Display Name, as X may be different depending on the server OS. The PowerShell Name always uses 45 instead of the actual version.

Role or FeatureDisplay NameNameNotes
Web ServerWeb Server (IIS)Web-Server
Web Server Common HTTP FeaturesDefault DocumentWeb-Default-DocIncluded in Web-Server.
Directory BrowsingWeb-Dir-BrowsingIncluded in Web-Server.
HTTP ErrorsWeb-Http-ErrorsIncluded in Web-Server.
Static ContentWeb-Static-ContentIncluded in Web-Server.
Web Server Health and DiagnosticsHTTP LoggingWeb-Http-LoggingIncluded in Web-Server.
Web Server PerformanceStatic Content CompressionWeb-Stat-CompressionIncluded in Web-Server.
Dynamic Content CompressionWeb-Dyn-Compression
Web Server SecurityRequest FilteringWeb-FilteringIncluded in Web-Server.
Basic AuthenticationWeb-Basic-AuthOnly required if using 1E ITSM Connect .
IP Address and Domain RestrictionsWeb-IP-SecuritySee note below.
Windows AuthenticationWeb-Windows-Auth
Web Server Application Development.NET Extensibility 4.XWeb-Net-Ext45Included in Web-Asp-Net45.
ASP.NET 4.XWeb-Asp-Net45
ISAPI ExtensionsWeb-ISAPI-ExtIncluded in Web-Asp-Net45.
ISAPI FiltersWeb-ISAPI-FilterIncluded in Web-Asp-Net45.
Web Server Management ToolsIIS Management ConsoleWeb-Mgmt-Console
.NET Framework 4.X Features.NET Framework 4.XNet-Framework-45-Core
ASP.NET 4.XNet-Framework-45-ASPNET
Message QueuingMessage QueuingMSMQOnly required for ActiveEfficiency server.

AI Model file download requirements

1E Catalog 2.0 supports downloading AI Model files for the AI auto-curation feature, which is used in other applications such as AppClarity and Application Migration via the SLA component in Tachyon.

In order to use the AI Powered Auto-curation feature you will need to have:

  • Tachyon 5.0 or later installed. Please refer to Tachyon 5.0 - Installing and upgrading for more details on installing Tachyon 5.0.
  • 5GB of available disk space on the computer hosting 1E Catalog for the initial download of the AI model files.
  • Around 5GB of additional available disk space on the computer hosting 1E Catalog for each subsequent update for the AI model files. The AI model files may vary in size in future updates. Currently, the previous version of the AI model files will not be deleted when the newer version is downloaded. You can safely remove the previously downloaded older versions by hand when newer versions become available to free up disk space.
  • The AI Powered Auto-curation feature also has some extra memory requirements. Please refer to Tachyon 5.0 - AI Powered Auto-curation: Increase in memory requirements for SLA for more details.

The files will be downloaded to the following directory:

C:\ProgramData\1E\Catalog\CatalogSynchronization\PredictionModel

1E Companion Products

Supported versions of 1E companion products that 1E Catalog 2.0 features depend on.

Products and features that 1E Catalog depends onSupported versions of companion products

None

n/a

n/a

Supported versions of 1E companion products with features that depend on 1E Catalog 2.0.

Products and features that depend on 1E CatalogSupported versions of companion products
AppClarityRequired by all AppClarity features.
  • AppClarity 7.0 and Tachyon 5.0
Application MigrationRequired by all Application Migration features.
  • Application Migration 3.0 and Tachyon 5.0
Tachyon

Required by all Tachyon features.

Tachyon Setup 5.0 includes the 1E Catalog 2.0 installer, and should be used when installing Tachyon and 1E Catalog on the same server. If an older version of 1E Catalog is installed then it will be upgraded by Tachyon Setup.

If Tachyon is to be installed on a different server, then 1E Catalog must be installed first.

  • Tachyon 5.0

Firewall Ports

PortsTrafficNotesConfigurable
TCP 443 (HTTPS)Outbound

The default protocol to connect to the 1E Cloud Catalog is ( https://catalog.1e.com ) for updates and downloads.

Yes, post-installation.
TCP 80 (HTTP)Outbound

Connects to the 1E Cloud Catalog ( http://catalog.1e.com ) for updates and downloads.

Yes, post-installation.
TCP 80 (HTTP)Inbound

Browsers used by administrators to connect to the CatalogWeb website and consumers of the 1E Catalog, for example AppClarity or SLA Platform.

Yes, during installation using the IISPORT property.

Post-install, by re-configuring the website binding.

Refer to the Communication Ports page for a comprehensive list of ports used by 1E Catalog combined with SLA in Tachyon 5.0.

Constraints of Legacy OS

In this documentation, the following are referred to as legacy OS. 1E does not provide support for 1E products on the following OS unless the OS is explicitly listed as being supported for a specific 1E product or product feature. This is because Microsoft has ended mainstream support for these OS or they are not significantly used by business organizations.

  • Windows XP
  • Windows Vista
  • Windows 7
  • Windows 8.0
  • Windows 8.1
  • Windows Server 2003
  • Windows Server 2008
  • Windows Server 2008 R2
  • Windows Server 2012
  • Windows Server 2012 R2

Please contact 1E if you require support for these legacy OS. If you experience an issue on these OS, then please try replicating the issue on a supported OS.

For Microsoft product lifecycle details, please refer to https://support.microsoft.com/en-us/lifecycle/search.