Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

Please read the Preparation page to review the implementation decisions you need to make before choosing one of the following upgrade paths:

Note

All the upgrade scenarios assume that Catalog 1.2 is installed on the same server as SLA 3.3.



Advanced Panelboxes for Confluence
namegrey
titleOn this page:
Table of Contents
maxLevel3
minLevel2
indent20px


Upgrading to Application Migration 2.5.200 on SLA Platform 3.3

Unless you specifically require Tachyon real-time features or the 1E ServiceNow integration features (Service Catalog Connect or ITSM Connect), you can upgrade Application Migration on your existing SLA Platform.

Note
If you are currently running SLA Platform 3.2, you must upgrade that to 3.3 first. Please refer to Upgrading SLA Platform

To upgrade to Application Migration 2.5.200:

  1. Apply the latest accumulated hotfix for SLA Platform 3.3. Please visit https://1eportal.force.com for more details on the available hotfixes for all 1E products.
  2. Follow the instructions under Installation: Installing Application Migration.
    1. When the upgrade completes, open the SLA Platform console.
    2. Under the Settings menu, click Repositories.
    3. Choose the default Application Migration repository and click Refresh to synchronize your data and to generate a report.
    4. If the SLA Platform was recently upgraded, run a full synchronization for its associated inventory instances.
  3. Follow the instructions under Installation: Upgrading 1E Task Sequence Tools.

Upgrading to Application Migration 2.5.200 and Tachyon 4.1

If you require Tachyon 4.1 real-time features or the 1E ServiceNow integration features (Service Catalog Connect or ITSM Connect) and have chosen to upgrade your existing SLA Platform 3.3 server to Tachyon 4.1 rather than implement an additional server for Tachyon, refer to Implementing Tachyon for details on how to prepare for and install Tachyon 4.1 using Tachyon Setup. Running Tachyon Setup on an existing SLA Platform 3.3 server will upgrade SLA Platform to Tachyon 4.1.

Multiexcerpt include
MultiExcerptNameTachyon_4_1_Account_Permissions
PageWithExcerptPreparation

Note
titleHTTP Port Web site configuration in Tachyon Setup

When upgrading SLA Platform 3.3 to Tachyon 4.1 and configuring Website Configuration in Tachyon setup, you should specify the current SLA Platform port in the HTTP Port configuration (host header and HTTP / HTTPS ports) settings. For example, if SLA Platform 3.3 was installed with the default settings (HTTP on port 8080 and HTTPS on 8443), you should set the HTTP Port to 8080 and HTTPS Port to 8443 in the Website Configuration page of the Tachyon Setup Wizard.  If a Host Header was used for SLA Platform, ensure the same host header is used for Tachyon. This will ensure your existing Application Migration Task Sequence steps and Shopping integration settings will continue to work after the upgrade and , will also prevent integration errors with the existing Catalog website (refer to Known issues) and will also ensure other websites installed in the Default Web Site will continue to be accessible using the server FQDN in the URL. If SLA Platform was configured to use HTTPS it is likely that you will need to generate a new Web Server certificate for Tachyon that meets the additional requirements of Tachyon (refer to Tachyon Preparation - Web Server Certificate for more information).

After upgrading to Tachyon 4.1, complete the following to upgrade to Application Migration 2.5.200:

  1. If the SQL Server hosting the Tachyon databases is on a different server or a named instance on the Tachyon server - or if you intend to use the Patch Success feature of Tachyon, apply the latest accumulated hotfix for Tachyon Platform SLA. Please visit https://1eportal.force.com for more details on the available hotfixes for all 1E products and refer to the readme notes for details on any manual steps associated with installing the hotfix.
  2. Follow the instructions under Installation: Installing Application Migration.

    Warning

    You should install Application Migration using the same account used to install Tachyon (Tachyon Installation Account).


  3. Follow the instructions under Upgrading 1E Task Sequence Tools.
  4. Users are the only SLA Platform 3.3 settings that are not migrated, so you will need to manually add these to Tachyon as follows. Please refer to the Tachyon 4.1 - Users page for further details on how to add users and assign roles in Tachyon.

Migration of platform users

Upgrading SLA Platform v3.3 to Tachyon v4.1 does not migrate the existing users automatically. They need to be added manually to Tachyon after the upgrade. When SLA Platform is upgraded to Tachyon Platform v4.1, only the user that ran Tachyon Setup will have access to Tachyon portal to manage users. Moreover, the user that performed the installation has restricted roles in the Tachyon portal that cannot be modified.

After finishing installation, log in to Tachyon portal using the account which was used to run the upgrade process and perform the following steps:

    • Add at least one user with the 'Global Administrators' role (this should have been done if you followed the Tachyon post-installation steps). This can be a user which was present in SLA Platform v3.3 or it can be an altogether new user. Please follow the steps as shown opposite:

      After this initial installation/configuration, either the installation user or the Global Administrator can add/remove users.

    • Add any other users that will need to use Application Migration. Users that are only working in the Application Migration application (e.g. managing rules and role-based applications and previewing devices) do not require any additional roles in Tachyon - they just need to be added as Tachyon users.
       
    • Add a user required by the Credentials (for web service call) setting in the 1E Application Migration task sequence step.
      Multiexcerpt include
      MultiExcerptNameAppMigTaskSequenceCredentials
      PageWithExcerptPreparation
    • If users other than the Global Administrators are required to work within what was previously Settings in SLA Platform 3.3 (e.g. to manage Repositories, Management Groups, Connectors and Schedules), they must be added and granted the following roles in Tachyon: 
      Multiexcerpt include
      MultiExcerptNameTachyonRolesForSLAadmins
      PageWithExcerptPreparation

Upgrading 1E Task Sequence Tools

To upgrade the 1E Task Sequence Tools, follow the instructions under the Installation: Installing the 1E Task Sequence tools heading using the latest version of 1ETaskSequenceTools.msi.

After the upgrade, existing task sequences that included the Application Migration step will continue to work, provided you have not changed the Base URL of the SLA Platform or Tachyon server.

The Properties page for the step will reflect the layout for the version of the 1E Task Sequence Tools in which the step was originally added to the Task Sequence. You should replace these in due course by removing the existing Application Migration step and adding a new one in its place. If you do not do that, you will not benefit from the new functionality (introduced in v2.5.100) which provides support for TLS 1.1/1.2.

After upgrading 1E Task Sequence Tools, any new Application Migration step added to a Task Sequence will show the version 2.5.200 properties page. The screenshot opposite shows the properties page for 1E Application Migration installed with 1E Task Sequence Tools v2.5.200.