Summary

A list of all the platforms supported by Application Migration and the software required to allow Application Migration to be installed and work correctly.

Because Application Migration is a consumer for the SLA Platform, the list of Supported Platforms for Application Migration is identical to that product.

The Application Migration Task Sequence step requires PowerShell v4 or greater (included in Windows 8 and later).

The Application Migration step executes in a Configuration Manager OS deployment task sequence after the new OS is installed. If you are deploying Windows 7 images, upgrade PowerShell in the image or install it using a task sequence step before executing the Application Migration step.

On this page:

Supported Platforms

The following table shows the supported versions of software used by the SLA Platform.

CategoryProductNotes

Server OS

  • Windows Server 2019
  • Windows Server 2016
  • Windows Server 2012 R2
The SLA Platform engine, integrate agent and integrate manager services will install on systems running these server OS.

SQL Server

  • SQL Server 2017
  • SQL Server 2016 SP2
  • SQL Server 2016 SP1
  • SQL Server 2014 SP2

SQL Server Standard or Enterprise edition is recommended.

You must enable the following before installation:

  • ensure the Collation on the SQL Server instance is case-insensitive and accent-sensitive (the preferred collation is SQL_Latin1_General_CP1_CI_AS)
  • enable the Common Language Runtime (CLR) integration feature on the SQL Server instance
  • enable the TCP/IP and Named Pipes protocols for local and remote database access
  • ensure the SQL Server Browser service is enabled and running if the SLA Platform website and the SQL Server instance are on different servers

See SQL Server requirements.

If a default SQL instance is not found on the local server, the Typical installation option is disabled.

The installer checks to see if databases with the following names already exist:

  • SLA-Data
  • SLA-Shared
  • SLA-Integrate
  • SLA-Identity

For each of these:

    • if the database does not exist, the installer will create the database and the objects for it
    • if the database does exist, it will update it with the latest objects

If installing the Business Intelligence (BI) feature then you will also need the following:

  • On the SQL instance hosting the SLA databases:
    • Install the SQL Server Client Tools Connectivity feature

  • SQL Server Analysis Services (SSAS) instance
    • this is required only if using the Business Intelligence (BI) feature, which requires SLA Platform as a prerequisite
    • the Analysis Services feature can be installed on the same SQL Server as other SLA databases, where it will have its own AS instance, or on a remote server
    • the AS instance can be local or remote to the web server
    • the AS instance must be installed in Multidimensional mode

Web server

  • IIS 10
  • IIS 8.5
  1. You must have one of these Web servers installed.
  2. The installer must be run on the system hosting the Web server as it deploys the SLA Platform Web site on it.
  3. See Server Roles and Features for details of required IIS features.
  4. You must enable these MIME content types (this can be done after installation):
    • application – application/x-ms-application
    • .deploy – application/octet-stream
    • .manifest – application/x-ms-manifest

The MIME types option in IIS manager will not be displayed if static content is not enabled. On some platforms, static content is not enabled by default which causes SLA Platform website not to initialize as the CSS and script content is not available.

Runtime libraries

  • .NET Framework 4.7.2
  • .NET Framework 4.7
  • .NET Framework 4.6.2
  • The SLA Platform services and Web UI will use any of these runtime libraries
  • See Server Roles and Features for details of required .NET Framework features.

Browsers

  • Google Chrome
  • Internet Explorer 11
  • Microsoft Edge
  • Mozilla Firefox
All Web client components are accessible through these browsers.

Others

  1. Internet connection
  2. 1E Catalog
  3. Application Migration
  1. The installer requires an active Internet connection to validate the signed database upgrade DLLs otherwise the installation will fail.
  2. You must install 1E Catalog 1.2 or later before you run the SLA Platform installer. Make note of the account details and the database server where you installed the catalog as you will need these when you install the platform.
  3. If you currently have Application Migration 2.0 (which uses SLA Platform 3.2) then you will need to upgrade to Application Migration 2.5 (which uses SLA Platform 3.3).

1E Companion Products

Supported versions of 1E companion products that Application Migration 2.5.200 features depend on.

Products and features that Application Migration depends onSupported versions of companion products
SLA Platform

Required by all Application Migration features.

  • SLA Platform 3.3 (with accumulated hotfix Q20631) and 1E Catalog 1.2 
TachyonAlternative to SLA Platform.
  • Tachyon 4.1

Application Migration 2.5.0 is supported only on SLA Platform 3.2, it is not supported on SLA Platform 3.3.

Application Migration 2.5.100 is supported on SLA Platform 3.2 and 3.3.

Application Migration 2.5.200 is supported on SLA Platform 3.3 (with accumulated hotfix Q20631) and Tachyon 4.1.

Supported versions of 1E companion products with features that depend on Application Migration 2.5.200.

Products and features that depend on Application MigrationSupported versions of companion products
ShoppingSelf-service OS deployment integrated with Application Migration. Optional feature.
  • Shopping 5.5.200

  • Shopping 5.5.100
  • Shopping 5.5


System Center Configuration Manager connector

The list below shows the versions of Configuration Manager supported by SLA Platform. Please refer to the System Center Configuration Manager connector page in SLA Platform documentation for detailed prerequisites and configuration.

  • CB 2002
  • CB 1910
  • CB 1906
  • CB 1902
  • CB 1810
  • CB 1806
  • CB 1802
  • CB 1710